Symptom
When adding a service product to a contract the following error occurs: Quantity type code must be time.
Reproducing the Issue
- Go to the Sales Orders work center
- Go to the Contracts View.
- Created a New Contract.
- Select account ID ABC in the General tab (ABC represents the ID of the customer account).
- Go to the Items tab and select Add Row button.
- Tick the option Price per period.
- Add a service product XYZ (XYZ represents the ID of the service product).
- Maintain a list price for the product. and select the Save button.
- Go to Pricing and Invoicing tab -> Select the Invoice Schedule sub tab.
- Select the Add Item button and add the product XYZ.
- The following error occurs:
Item 10 : Quantity type code must be time.
Cause
The Pricing Per Period indicator is disabled for quantity types such as Wday, however, it is enabled for types hour, day.
You can test the above suggestion by following below steps:
- Go to the Sales Orders work center
- Go to the Contracts View.
- Created a New Contract.
- Select account ID ABC in the General tab (ABC represents the ID of the customer account).
- Go to the Items tab and select Add Row button.
- Add a service product XYZ before ticking the option Price per period (XYZ represents the ID of the service product).
- The Price per period is now disabled because it cannot be used for wday (as explained above).
Resolution
To solve the error either use the valid UoM (unit of measure) such as hour, day or create customized UoM's referring to hour, day etc.
Follow the steps below to create the customized UoM's:
- Go to the Business Configuration work center.
- Go to the Overview view.
- Find & open the activity Quantities and Units of Measure.
- Select the link Create and Maintain Physical Units.
- Maintain a customized unit (e. g. c-days) referring to the standard quantities such as hour or day.
Keywords
KBA , AP-SLO , Sales Order Processing , How To
Product
SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1711