SAP Knowledge Base Article - Public

1752459 - Oracle Server missing from the Connection list in Crystal Reports

Symptom

  • Oracle Server missing.
  • Oracle Server not listed when creating a new connection.
  • Unable to create a new connection to Oracle using a native connection in Crystal Reports.
  • Oracle Server is not displayed under "Create New Connection" in the "Database Expert" of Crystal Reports.
  • Oracle Server listed in Crystal Reports, when logged on as the Administrator of the computer, but not for other MS Windows Users.   
              
  • Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016
  • SAP Crystal Reports 2020
  • SAP Crystal Reports 2025
                  
  • Oracle 12c
  • Oracle 12c R2
  • Oracle 18c
  • Oracle 19c
  • Oracle 21c
         
  • MS Windows Server 64 bit environment

Reproducing the Issue

  1. Install and configure the Oracle Client.
  2. In Crystal Reports, create a new report.
  3. In the "Database Expert", notice the Oracle Server is not in the list of available data source.
     
    Oracle Server Missing - 01.png

Cause

  • For Crystal Reports 2013, 2016:
    • If you installed a 64bit Oracle Client, Crystal Reports will not be able see the Oracle Client because Crystal Reports 2013, 2016 are 32bit applications.
        
  • For Crystal Reports 2020, 2025:
    • If you installed a 32bit Oracle Client, Crystal Reports will not be able see the Oracle Client, because Crystal Reports 2020 adn above are 64bit application. 
          
  • If you have both 64bit, and 32bit Oracle Client installed on the same computer, it causes the issue not being able to access the correct Oracle Client for the version of Crystal Reports used.

Resolution

  • Install and configure the 32bit, or 64bit Oracle Client depending on the version of Crystal Reports used:
    1. Confirm the version of Oracle that is supported for the version of Crystal Reports used, by reviewing the supported platforms document available in the SAP Knowlege Base Article 2859510 
             
    2. Install the 32bit, or 64bit Oracle Client depending on the version of Crystal Reports used, that match the version of Oracle you are using.
      For example: For Oracle 12c, and Crystal Reports 2016, install and configure the 32bit Oracle 12c Client.

      • For Crystal Reports 2013, 2016: Install the 32 bit Oracle Client.
      • For Crystal Reports 2020, 2025: Install the 64bit Oracle Client.
                 
    3. Configure the Oracle Client to point to your Oracle data source.       
                    
  • If the Oracle Server option is still missing after installing and configuring the 32bit or 64bit Oracle Client that correspond to the version of Crystal Reports used, then it's because it still points to the incorrect Oracle Client. This generally occurs when you have both a Oracle Client installed on the same computer. To ensure it is pointing to the 32bit, or 64bit Oracle Client, then:
    1. Change the order of the path to the Oracle Client, in the MS Windows Environment Variable:
         
      • For Crystal Reports 2013, 2016:
        Add the 32 bit path to the PATH environment variable right after the 64 bit path. For example: 
          
        PATH=C:\Ora11g64\product\11.2.0\client_1\bin;C:\Ora11g32\product\11.2.0\client_1\bin;C:\Windows\system32;C:\Windows;...

          
      • For Crystal Reports 2020, 2025:
        Add the 64 bit path to the PATH environment variable right after the 32 bit path. For example: 

        PATH=C:\Ora11g32\product\11.2.0\client_1\bin;C:\Ora11g64\product\11.2.0\client_1\bin;C:\Windows\system32;C:\Windows;...

                   
    2. Set the Oracle registry key: TNS_ADMIN, to point to the location of the tnsnames.ora, for the 32bit, or 64bit Oracle Client
        
      2.1  Start the Microsoft Windows Registry editor (regedit)
          
      2.2 Navigate to the your Oracle client registry:               

            For Crystal Reports 2013, 2016:
           - Go to the 32bit Oracle Client:  HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ORACLE

           For Crystal Reports 2020, 2025:
           - Go to the 64bit Oracle Client registry :  HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE

      2.3 Right click on your Oracle folder entry, and select in the contextual menu  "New - String Value" and create: TNS_ADMIN registry key

      2.4 Add the 32bit, or 64bit path to the Oracle Client depending on the version of Crystal Reports used:


           For Crystal Reports 2013, 2016: 
           - In the TNS_ADMIN, add the path to the 32 bit Oracle Client location of the tnsnames.ora on your hard drive.   

           For Crystal Reports 2020, 2025:
           - In the TNS_ADMIN, add the path to the 64 bit Oracle Client location of the tnsnames.ora on your hard drive.   
       
           Below is an example:     
         
             Edit-String.jpg             

Keywords

Oracle missing, no Oracle Server, No native Oracle connection, CR , KBA , crystal reports , oracle , connectivity , 64 bit , path , tns_admin , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2016 ; SAP Crystal Reports 2020 ; SAP Crystal Reports 2025