SAP Knowledge Base Article - Public

1757258 - The Reason for Rejection Field is not Editable on the Sales Order Header

Symptom

The Reason for Rejection field is not editable on the sales order header

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Go to the Sales orders view.
  3. Show All Orders and Find ABC (ABC represents the ID of the sales order).
  4. Edit the sales order and select the View All button.
  5. Go to the General tab.
  6. The Reason for Rejection field is not editable, hence the sales order cannot be canceled at header level.

Cause

The Reason for rejection field at header of the sales order could be set/editable only if the delivery status for all items is Not Started, else it remains un-editable and items need to be canceled individually.

Resolution

  1. Go to the Sales Orders work center.
  2. Go to the Sales orders view.
  3. Show All Orders and Find ABC (ABC represents the ID of the sales order).
  4. Edit the sales order and select the View All button.
  5. Go to the Items tab.
  6. Select each item individually and set the Reason for Rejection.
  7. Save your changes, this will set the status of the Sales Order to Completed.

Keywords

Sales Order, Reason for rejection, Header level; , KBA , reason for rejection , sales order , AP-SLO , Sales Order Processing , How To

Product

SAP Business ByDesign all versions

Attachments

ChineseTranslationOnly_1757258.pdf