SAP Knowledge Base Article - Public

1757386 - The Customer Return Show an Error Message Reference Sales Order Missing, Though the Reference Sales Order is Already Maintained for the Return

Symptom

The Customer Return show error message Reference Sales Order Missing, though the reference sales order is already maintained for the return.

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Go to the Returns view.
  3. Show All Returns and Find ABC (ABC represents the ID of the return).
  4. Edit the return.

The following Error occurs : Reference Sales Order missing.

Cause

The return ABC is created for the sales order XYZ for which the delivery is not complete. The Outbound Delivery created for the sales order is still in the Not Released status.

Note:
ABC represents the ID of the customer return.
XYZ represents the ID of the reference sales order.

Resolution

  1. Go to the Outbound Logistics work center.
  2. Go to the Outbound Delivery view.
  3. Search for the delivery DEF (DEF represents the ID of the delivery created for the reference sales order).
  4. Edit the delivery DEF.
  5. Release the delivery DEF.
  6. Cancel the return (Follow the case document 1589551 - How to Cancel a Customer Return).
  7. Re-trigger the processing of customer return after the completion of the outbound delivery.

For creation of a consistent return it is required to complete the delivery process.

Keywords

KBA , AP-SLO , Sales Order Processing , How To

Product

SAP BUSINESS BYDESIGN 1705 ; SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1302 ; SAP Business ByDesign 1305 ; SAP Business ByDesign feature pack 3.0 ; SAP Business ByDesign feature pack 3.5 ; SAP Business ByDesign feature pack 4.0