Symptom
Error occurs while releasing the service order: Order Item XXX not fulfilled; service confirmation does not exists.
Reproducing the Issue
- Go to the Service Orders work center.
- Go to the Service Order Processing view.
- Show All Orders and Find XYZ (XYZ represents the ID of the service order).
- Choose Go button.
- Select the service order XYZ and choose the Edit button.
- Select the View All button and go to the Services and Spare Parts tab.
- Select the line item XXX and choose the Complete Execution button (XXX represents the ID of the item).
- Error occurs Order Item XXX not fulfilled; service confirmation does not exists.
Cause
The line item XXX of the service order XYZ is of type Advanced Ship which means that materials are requested for this service.
So, ideally once the item is released for execution, there will be a customer demand created at SCM side and once the customer demand is released, an outbound delivery should be created & released. With the completion of SCM steps the released quantity will be updated in service order Confirmed Quantity field.
After the above process when we create service confirmation for this item, the reference will be copied in service confirmation and the quantity also should be updated in it.
In the service order XYZ, the Confirmed Quantity is blank so even though service confirmation is created it is not valid, these confirmations are allowed to be created to enter if any other service or materials were consumed for same service order and it is not related to that item.
So when it tries to complete the execution it always finds the related service confirmation is not present and fulfilled.
Resolution
To solve the error message on the service order you need to complete the documents at SCM side as the line item in the service order is of type Advanced Ship:
Follow the steps below once the service item is released for execution:
- Release the customer demand created for the service item in the Outbound Logistics Control work center.
- Create and release the outbound delivery created for the service item in the Outbound Logistics work center.
With the completion of the above SCM steps, the released quantity will be updated in service order Confirmed Quantity field. Hence now you can create a service confirmation for the item XXX.
Keywords
KBA , AP-SVO , Service Order Processing , How To