Symptom
When you try to create a Service Agent, system throws below error message:
Creating Employee not possible; number range interval APHCF1_AP_HCF_EMPLOYEE_EXT_01 missing
Reproducing the Issue
- Go to Business Configuration work center.
- Select Implementation projects view.
- Select Open Activity List button.
- Go to Prepare Phase.
- Select Define Key Users of the Project activity.
- Select Create Service Agent button.
Cause
The cause for the error message is that there is no number range set in the system for Service Agents.
The deployment might have is not yet done in the system and therefore also no number ranges are available. Which means the scoping activity has not been completed. This has to be done before, so it is possible to define the key user (as here the number ranges are needed). An explicit confirmation is requested by opening of the activity and confirming this milestone.
Hint: The standard number range for service agent IDs is 0 - 6999999. If you have different requirements for service agent IDs, go to the optional Number Ranges for Employees and Service Agents activity in the Fine-Tune phase and make adjustments accordingly.
Then you can able to create a Service Agent without any issues.
Resolution
The system works as designed.
See Also
You can also refer to the document 1781056 - Unable to Create Service Agents in Prepare Phase Activity
Keywords
KBA , AP-RC-BCT , Business Config. Tools (SAP Business ByDesign , Product Enhancement