Symptom
The Created By field of the Phone Call Activity display inconsistent value.
Reproducing the Issue
- Go to the Marketing work center.
- Go to the Campaigns view.
- Search for the campaign XYZ (XYZ represents the ID of the campaign).
- Edit the campaign and select the View All button.
- Go to the Response Details tab.
- Find the Phone Call Response ID ABC (ABC represents the ID of the phone call activity).
- In the table the Created By value is shown as DEF (DEF is the ID of user 1)
- Select the ID ABC to open the Phone Call Activity.
- Here the employee responsible is GHI (GHI represents the ID of the user 2).
You expect the Created By field should also show GHI.
Cause
During the creation of a Phone Call Activity:
- Created by - is by default assigned to the login user.
- Employee responsible - is also by default assigned to the login user.
However, the Employee responsible can be edited and can be assigned to a different employee.
The scenario could be the same as described below
During creation of the Phone Call Activity:
- Created by - User DEF.
- Employee responsible - User DEF.
The value of employee responsible has been edit later on, so after edit
- Created by - User DEF.
- Employee responsible - User GHI.
This is the designed behavior of the SAP Business ByDesign.
Resolution
This is the expected behavior of the SAP Business ByDesign.
Keywords
KBA , SRD-CRM-OPP , Opportunities , How To
Product
SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1302 ; SAP Business ByDesign 1305 ; SAP Business ByDesign 1711 ; SAP Business ByDesign feature pack 3.0 ; SAP Business ByDesign feature pack 3.5 ; SAP Business ByDesign feature pack 4.0