Symptom
External Customer Invoice Request cannot be uploaded.
Reproducing the Issue
You uploaded External Customer Invoice Requests via WebDav but the External Customer Invoice Requests did not arrive in your Invoice Requests view in the Customer Invoicing work center.
- Go to the Application and User Management work center.
- Select the Input and Output Management view and the File Input sub view.
- Select the Run ABC (ABC represents the Run ID).
- Select the Execution Details tab in the Details section.
- Select the hyperlink 12345 in the Application Log ID field (12345 represents the Application Log ID).
- A new window will open with the application log details.
- Navigate to the Results tab.
- The following message is displayed:
Product change for item 10 not allowed after invoicing.
Cause
The External Customer Invoice Request cannot be uploaded because there are already existing External Customer Invoice Requests in the system with the same Document ID's which have been already invoiced. When the you are uploading an External Customer Invoice Requests with the same Document ID as an existing External Customer Invoice Requests the system will try to update the existing External Customer Invoice Requests with the new data. In this case the system cannot update it anymore since the existing External Customer Invoice Requests already has been invoiced and no changes are allowed after invoicing.
Resolution
Please ensure that the Document ID of the Uploaded Invoice Requests are unique. This means that in the Excel Template for the Invoice Upload in the column Document ID you need to specify a number which has not been used before if you do not want to update an existing External Invoice Request which has not been invoiced so far.
To upload the remaining Invoice Requests which have failed, you need to change the numbering of the Document ID’s in the Excel Template, generate a new XML file and then upload the files again.
Keywords
KBA , AP-CI-CIR , Customer Invoice Request , How To