SAP Knowledge Base Article - Public

1793967 - Error: 'Error in business conf.: item type code not determined; report case' occurs when Entering a Product into a Service Order

Symptom

The following error occurs when entering a product into a service order:

Item 10: Error in business conf.: item type code not determined; report case.

Reproducing the Issue

  1. Go to the Service Orders work center.
  2. Select the Service Order Processing view.
  3. Press the New button and select the Service Order option.
  4. Enter all respective data.
  5. Press the View All button.
  6. Go to Service and Spare Parts tab and enter product ABC (ABC represents the number of the product).
  7. Following error message occurs:

Item 10: Error in business conf.: item type code not determined; report case.

Cause

The product ABC is of the item group DIGI - Spare part - direct goods issue.

The following scoping question has been answered with No:

When executing a service order, do your service engineers perform a direct goods issue by entering a logistic area for the spare parts used?

Hence, the item type DIGI cannot be sold in sales documents.

 

Resolution

If you would like to sell products of item type DIGI you need to change your scoping as follows:

  1. Go to the Business Configuration work center.
  2. Select the Implementation Projects view.
  3. Select your current project and press the Edit Project Scope button.
  4. Go to Step 4 Questions.
  5. Navigate to Service -> Product and Service Portfolio for Field Service and Repair -> Spare Parts Handling
  6. Go to the Questions for Spare Parts Handling section:
  7. The question: When executing a service order, do your service engineers perform a direct goods issue by entering a logistic area for the spare parts used? has to be answered with Yes.

See Also

2013633 - Error: Products w/ item group Spare part (engineer pick-up/sales) not supported for location of srv provision On-Site Occurs When Entering a Product into a Service Order

2209995 - Item of Item Group SERV - Service - Fixed Price Cannot be Added in a Service Order

Keywords

KBA , AP-SVO , Service Order Processing , How To

Product

SAP Business ByDesign all versions