Symptom
On clicking Complete Execution button for the service order, warning message : Item XX: Order item XX not fulfilled; service confirmation YY1 not fulfilled is triggered, even though service confirmation is already in status Finished.
Reproducing the Issue
- Go to the Service Orders work center.
- From the Common Task, click on the New Service Order.
- In the New Service Order screen, enter ABC (where ABC represents the Account name) and click on the View All button.
- Go to the Services and Spare Parts tab and click on the Add Row button.
- Enter the service item PQR (where PQR represents the Service Product name), which is of type Fixed Price.
- Click on the button Submit->Release to Service Execution. The service order id LMN (where LMN represents service order name) is created.
- Go to the Field Service and Repair work center.
- Go to the Order Pipeline view.
- In the Show field from drop-down select All Orders to be Executed and in the Find field enter service order id LMN and click on the Go button.
- Click on button Confirm Execution, which will created Service Confirmation.
- Go to the Service Order work center.
- Go to Service Order Processing view and in the Find field enter service order id LMN and click on the Edit button.
- Go to Services and Spare Parts tab and click on the button Complete Execution.
Warning message:Item XX: Order item XX not fulfilled; service confirmation YY1 not fulfilled is triggered.
Cause
The cause of warning message is as below:-
You have created two Service Confirmation name YY1 and YY2 for the Service Order LMN.
- 1st Service Confirmation Id YY1: Which is created and saved for all quantities included in service order LMN ,but not released .Hence service confirmation is with status Not Started.
- 2nd Service Confirmation Id YY2: Which you have created and Release->Without Order Completion. Hence Service Confirmation is with status Finished for all the quantities included in the respective service order LMN.
Resolution
In order to solve the warning message,you need to delete the Not Started service confirmation YY1(As all the quantities are already Finished via service confirmation YY2) and later perform Complete Execution for Service Order.
- Go to the Field Service and Repair work center.
- Go to the Service Confirmation view and in the Find field enter YY1.
You can see the button Delete is editable, since status of Service Confirmation YY1 is with status Not Started. Click on the Delete button.
- Go to the Service Order work center.
- Go to the Service Order Processing view and in the Find field enter LMN and click on the Edit button.
- Go to the Services and Spare Parts tab and click on the button Complete Execution.
You should be able to proceed successfully without and warning message.
Keywords
KBA , AP-SCO , Service Confirmation Processing , How To