Symptom
When you enter step 3.1 Configure CA Wily Introscope in Basic Configuration the following error is shown:
SoapFaultCode:5 Cannot find java method with name ping and param-number 1 in object com.sap.sup.admin.setup.MangedSetupWSImpl@<Nb>.
Web service invocation problem on host <hostname> and port <port> protocol: http logical port name: LP_WS_MANAGED_SETUP
Could not ping web service on the solution manager java stack
Starting with SAP Solution Manager SP10 the error looks like below:
SoapFaultCode:4 com.sap.sup.admin.wily.jdbc.EMInfo.getProperty(Ljava/lang/String;)Ljava/lang/String;
Web service invocation problem on host cips228.hsec.emeadc001.philips.c and port 8028 protocol : http logical port name : LP_WS_MANAGED_SETUP. Check note 1822831.
SoapFaultCode:4 com.sap.sup.admin.wily.jdbc.EMInfo.getProperty(Ljava/lang/String;)Ljava/lang/String
Environment
- SAP Solution Manager 7.1
- SAP Solution Manager Diagnostics
Reproducing the Issue
1. Execute transaction solman_setup
2. Click Basic Configuration
3. Goto step 3.1 Configure CA Wily Introscope
Cause
A jar file part of the previous Java LM-SERVICE SCA versions, named managedsetup_ws.jar is not removed from the following location during the deployment, although it is no longer part of the SCA:
/usr/sap/<SolManSID>/<InstanceID>/j2ee/cluster/server<ServerNb>/apps/sap.com/tc~smd~managedsetup_ws/webservices_container/webservices/app_jars
Resolution
To solve this issue, perform the following steps:
1) Apply the latest J2EE Engine Patch levels, to deliver a correction to the issue described in note 1826492 - Inconsistency of WS container in cluster for the SAP Solution Manager System.
Check the relevant note for your Support Package, these notes provides the steps about how the J2EE Patch levels must be implemented.
| 1843689 - Solution Manager 7.1 SP Stack 10: recommended corrections |
| 1953075 - Solution Manager 7.1 SP Stack 11: recommended corrections |
| 2020219 - Solution Manager 7.1 SP Stack 12: recommended corrections |
| 2106807 - Solution Manager 7.1 SP Stack 13: recommended corrections |
2) In case the issue persists after apply the latest J2EE Engine Patch levels, then try to undeploy and redeploy the component LM-SERVICE in the SAP Solution Manager system.
3) In case the issue persists after the redeploy of component LM-SERVICE, then perform the steps below:
3.1) Navigate on OS level of all Solution Manager System instances and each time for all server nodes to /usr/sap/<SolManSID>/<InstanceID>/j2ee/cluster/server<ServerNb>/apps/sap.com/tc~smd~managedsetup_ws/webservices_container/webservices/app_jars
3.2) Before proceeding, first verify that in each of the above mentioned folders both managedsetup_ws.jar & ws_managedsetup.jar exist
3.3) If so, delete managedsetup_ws.jar
DO NOT delete file ws_managedsetup.jar
3.4) Restart the Solution Manager system.
Keywords
Web service invocation problem , KBA , SV-SMG-DIA-WLY , Solution Manager / Introscope Integration , SV-SMG-DIA-SRV-SET , Please use components SV-SMG-INS-CFG-SYP, -BSC, -MNG, -DIA , Problem
SAP Knowledge Base Article - Public