SAP Knowledge Base Article - Public

1820230 - Byte Code Adapter Installation error in Solution Manager 7.1 Managed System Configuration step Configure Automatically

Symptom

The following error occurs under:

Transaction SOLMAN_SETUP
  Managed Systems Configuration → 
   Configure Automatically 
     Byte Code Adapter Installation

Operation Failed - <SID> - : - java.rmi.RemoteException:
Problem getting VMManager; nested exception is:
com.sap.smdagent.vmmanager.VMManagerP4Exception:
com.sap.smdagent.plugins.connectors.p4.exceptions.P4AuthorizationException:
Access is denied to SAP System <SID> [<SID>/<instance number>]:
check the connection credentials.More details about the error in agent
'<host name>' log file (SMDAgentApplication.X.log).; nested exception is:
com.sap.engine.services.security.exceptions.BaseLoginException:
Error during authentication. For more information see the remote server traces.

Environment

SAP Solution Manager

Reproducing the Issue

  1. Open transaction SOLMAN_SETUP
  2. Go to section Managed Systems Configuration
  3. Select a system and click Configure System
  4. Go to step Configure Automatically
  5. Select activity Byte Code Adapter Installation
  6. Click Edit
  7. Click Execute Selected

Resolution

Make sure that the following steps have been carried out correctly:

  1. A user has been created as described in SAP note 1647157.
    You have ensured that a log on with this user works correctly.

  2. The user and the password from step 1 have been entered in section Managed System Configuration in step Enter System Parameters.

  3. In step Enter System Parameter ensure that the Message Server Port has the right internal port and HTTP port.
    Check in dev_ms log file for the correct port numbers
    → dev_ms is located in the work folder of the JAVA message server
    \usr\sap\<SID>\<instance name>\work


    dev_ms2.jpg


    In this case the HTTP message sever prot of JAVA Messager server is 8174 and internal port is 3974

  4. In step Enter System Parameters ensure that the password provided for the Setup user (Admin) is correct.
    Click Test Logon to test the logon and make sure that the user is not locked.


    KBA1.png

  5. Check if the username and password have the correct length in the AgentAdmin User Interface Application Configuration:
    1. Use shortcut http://<hostname>:<port>/webdynpro/dispatcher/sap.com/tc~smd~server~agent~admin/SMDAgentAdminApplication?sap-language=EN OR
      Open transaction SM_WORKCENTER and navigate to:

      Root Cause Analysis
       Solution Manager Administration →
        Infrastructure 
         Framework →
          Agent Framework →
           Agent Admin →
            All Agents →
             Application Configuration →
              Agent Applications →
               com.sap.smd.agent.application.global.configuration

    2. In drop down field Scope select the hostname of the affected managed system:

      KBA2.png

 

  1. Check SAP note 1647267 - Solution Manager adaptation to Java UME security
  2. Repeat the Byte Code Adapter Installation

    KBA3.png

Keywords

KBA , SV-SMG-DIA-WLY-BCA , Byte Code Agent Setup , Problem

Product

SAP Business ByDesign all versions