SAP Knowledge Base Article - Public

1825859 - Cannot Edit the Time Sheet for Service Agent

Symptom

You are trying to access the service agent time sheets to verify the hours entered against the project. However Edit Time Sheet button is grayed out in the Service Agents screen.

Environment

SAP Business ByDesign 2005 and higher.

Reproducing the Issue

  1. Go to the Supplier Base work center.
  2. Go to the Service Agents view.
  3. Select the relevant Service Agent.
  4. Edit Time Sheet button is grayed out.

Cause

The user role was changed from Employee to Service Agent, or vice versa. In this case, the Time Recordings of the Service Agent are not accessible via Edit Time Sheet button.

Other Possibilities: Also system makes the Edit Time Sheet button inactive in the service agent screen:

  • If the service agent has not time agreement.
  • If the service agent is/was an internal employee.
  • If a service agent is no more internal employee it should not be possible to confirm the time through the service agent screen. Means if employee is converted in to service agent.

Resolution

The Employee can log in the system with his business user and follow steps below:

  1. Go to the Home work center.
  2. Go to ESS Timesheet.
  3. Here the Employee can go all the way back to when he/she was still a Service Agent/Employee. 

The Employee will be able to see the time recordings as well and make new ones. These time recordings will then go for approval and will be booked once it's approved by the manager.

Note: Please be reminded that these time recordings have to be approved by the approver as none of these recordings will show up in the Time administration work center.

Keywords

Service Agent, Time Sheet, Grayed Out, Time Recording, Time Administration, Record Times. , KBA , SRD-HR-TLM , Time and Labour Management , How To

Product

SAP Business ByDesign all versions