Symptom
You have scoped the approval process for Sales Order and your Customer Demand is in status Delivery Blocked.
Environment
SAP Business ByDesign
Reproducing the Issue
Pre-requisite : You have scoped the approval process for Sales Order with a threshold of YYY $ (YYY represents the maintained amount value).
- Go to the Sales Order work center.
- Go to the Sales Order view.
- Edit the Sales Order XYZ (XYZ represents the identification of your sales order).
- Go to the Items tab.
- Select Items 10 and update the quantity.
- Go to the Outbound Delivery Logistic work center.
- Select the Customer Demand view.
- Select the Row for the Sales Order XYZ and Item 10 (XYZ - 10).
You can see in the detail information that a delivery block is set up. However, you do not expect this block as the total price of the Sales Order did not exceed YYY $.
Cause
This is the normal system behavior. When the sales order approval process is scoped, in case you update an existing order that would affect the pricing (total, net value,...), the corresponding Customer Demand for the sales order item will be set up to delivery block.
In order to remove the block you would have to select the action: Submit for Approval on the Sales Order. Once you have trigger this action:
- if the total amount of the order does not exceed the threshold value (YYY $ in our example), the order will be in status Approval not necessary and the delivery block will be removed in the customer demand.
- if the total amount of the order exceed the threshold value, the order will go to approval according to the rules you have set up.
- if there is no threshold value, however there is the profit and replacement delivery settings and you have changed the item quantity or UoM.
Resolution
- Go to the Sales Order work center.
- Go to the Sales Order view.
- Select the Order XYZ.
- Edit the Order and Select the Action > Submit to Approval
See Also
KBA 2619643 - Sales Order blocked
Keywords
sales order, customer demand, delivery, block, approval, process , KBA , #### , ###### , AP-CR-CR , Customer Requirement , How To
Product
Attachments
ChineseTranslationOnly_1833775.docx |