Symptom
The account name is not shown on the migrated sales order with error message: Postal codes, street, and, P.O. box in address of Account party missing", "City in address of Account party missing.
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Show All Orders and Find XYZ (XYZ represents the ID of the migrated sales order).
- Edit the sales order XYZ.
- In the Account field only ID is shown not the account name as it shows for other sales orders.
- Also error message appears on the sales order: Postal codes, street, and, P.O. box in address of Account party missing", "City in address of Account party missing.
Cause
You have added the country name in the migration template of the sales order. In general the address for the account of the sales order is determined based on the Account master data maintained in the system, but if you add the country in the migration template of the sales order then system considers it to be manual entry of data and will not determine the address of the account party.
Resolution
To avoid this problem in the migrated sales order it is advisable that before the migration you should remove the entry from the Country field for account in the migration template.
For already migrated sales order, following workaround can be applied:
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Show All Orders and Find XYZ (XYZ represents the ID of the migrated sales order).
- Edit the sales order XYZ.
- Manually remove the account ID from the Account field, press Enter, add the same account ID again.
- Save the sales order.
Now the sales order will show the account name without any error.
Keywords
KBA , AP-SLO-SO , Sales Order , How To