SAP Knowledge Base Article - Public

1837947 - Error: 'Connect to Message Server Failed' when refreshing a report based on an SAP BW Query in Crystal Reports, or in SAP BI LaunchPad

Symptom

  • Fails to logon.
  • Unable to refresh report based off an SAP BW BEx Query in Crystal Reports.
  • When performing a trace, it generates the error: 'Connect to Message Server Failed' 
  • When attempting to refresh a report based off an SAP BW BEx Query in SAP BI LaunchPad, it fails with the error:
              
      "The viewer could not process an event.  The database logon information for this report is either incomplete or incorrect.
      [] ------Error code:0[CRWEB00000119]"

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016
  • SAP Crystal Reports 2020
        
  • SAP BusinessObjects Business Intelligence Platform 4.1
  • SAP BusinessObjects Business Intelligence Platform 4.2
  • SAP BusinessObjects Business Intelligence Platform 4.3
           
  • SAP BW 7.4
  • SAP BW 7.5

Reproducing the Issue

  • In Crystal Reports:
    1. In Crystal Reports, open a report based off an SAP BW BEx Query.
    2. When refreshing the report, it fails to logon to the SAP BW Server.
        
  • In SAP BI LaunchPad:
      
    1. Refresh a report based off an SAP BW BEx Query.
    2. It fails with the error:  
         
      "The viewer could not process an event.  The database logon information for this report is either incomplete or incorrect.
        [] ------Error code:0[CRWEB00000119]"

Cause

  • When performing an SAP BW MDX Driver trace, the log file displays the following error:
      
         ERROR       service '<Server Name>' unknown
         'Connect to message server failed'

  • This indicates the report connects to an SAP BW Message Server (MHOST), and Crystal Reports is unable to connect to the SAP BW Message Server because the Message Server entry has not been added to the "services" file, or the Message Server port number is incorrect in the "services" file.

Resolution

  • Add the Message Server entry to the "services" file on the local computer where Crystal Reports is installed, or if you are experiencing the issue in SAP BI LaunchPad, then add it to the computer where the SAP BusinessObjects Business Intelligence Platform server is installed:
          
    1. Contact your SAP BASIS Administrator to confirm the port number for the Message Server you are attempting to connect to.
        
      Note: If you are the SAP BASIS Administrator, it is possible to verify the Message Server name and port number by login to the SAP System, and using transaction: SMMS.  In the Message Server Monitor, it will list the Message Servers and Port Number.
         
      Message Server - 2.png
            
          
    2. Edit the "services" file, located in the following directory:
        
          C:\Windows\system32\drivers\etc\services
          
    3. Add the Message Server entry. The entry will look like:
        
          sapms<SID>    <Port Number>/tcp  #SAP System Message Server Port
           
      For example, if the SAP Message Server <SID> is R79, and the port number is 3601, the entry to add to the services file will be like:
        
          sapmsR79       3601/tcp  #SAP System Message Server Port
         
    4. If the Message Server entry has already been added, confirm the port number is correct.
        
    5. Save the file.

Keywords

CR, SAPBW , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , BI-BIP-ADM , BI Servers, security, Crystal Reports in Launchpad , Problem

Product

SAP Crystal Reports 2013 ; SAP Crystal Reports 2016 ; SAP Crystal Reports 2020