SAP Knowledge Base Article - Public

1840440 - Incorrect data set returned in Crystal Reports, when filtering the saved data of a report

Symptom

  • Incorrect data returned on the report.
  • Changing parameter value does not change the report data, or returns the wrong data set.
  • Incorrect data returned in Crystal Reports when selecting a different value for a parameter in the Preview Panel.
      
       
  • Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Crystal Reports 2008
  • SAP Crystal Reports 2011

Reproducing the Issue

  1. In Crystal Reports, create a report off any data source, and add few database fields to the report.
  2. Add a Report Bursting Indexes on a database fields that will be used in the Record Selection Formula.
    • Under the menu “Report”, select “Report Bursting Indexes…”
    • In the “Saved Data Indexes” window, add a database fields to the “Indexed for Bursting” list.
  3. Refresh the report. We need to refresh the report because the indexes will be created when the report is refreshed.
  4. Create at least one parameter on the report that will be used in the Record Selection.
  5. Create a Record Selection formula that contains a combination of the operators AND, OR, LIKE, = (Equal) and NOT, and uses parameters. 
    For example, create a Record Selection Formula like: 

    Not  ( {Customer.Customer ID} = 24 ) AND (({Customer.Country} LIKE "Ca????") OR({Customer.Country} = {?My Country Parameter} ))
        
  6. Refresh the report.
  7. In the Preview Panel window, modify the parameter value.

Report Bursting Indexe - 02.png

  1. Notice the report return the incorrect result set.

Cause

  • The Report Bursting Index is causing this issue.
  • The issue has been identified and logged under Problem Report ID ADAPT01679888.

Resolution

  • The issue is resolved in the following product update of Crystal Reports 2008:
    • Fix Pack 5.5
      •      
  • If you cannot apply the product update for some time, then to workaround the issue, remove the Report Bursting Index used on the report.
    1. Open the report in Crystal Reports.
    2. Under the menu "Report", select "Report Bursting Indexes..."
    3. In the "Report Bursting Indexes" window, remove the database fields from the list of "Indexed for Bursting" by clicking on the double left arrow button.

Report Bursting Indexe.png

    1. Refresh and save your report.

Keywords

CR , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

Crystal Reports 2008 V0 ; Crystal Reports 2008 V1 ; SAP Crystal Reports 2011 ; SAP Crystal Reports 2011, feature pack 03