Symptom
Sales Order are not available in the SAP ByDesign system. However, you are able to see the Sales Order in the Sales History of the respective Account and corresponding report.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Sales Order work center.
- Select the Sales Orders view .
- Search for the Sales Order ABC (ABC represents the ID of the Sales Order).
You will see that the Internet Sales Order does not appear in the SAP Business ByDesign system.
- Go to the Account Management work center.
- Go to the Accounts view.
- Show All Accounts and Find XYZ (XYZ represents the ID of the account for which Sales Order ABC was created).
- Open the Account Overview of ID XYZ.
- Go to the Sales tab.
- In the Sales History Report you can see Sales Order ABC.
- When opening the Sales Order from the Sales History the Submit button is grayed out.
Cause
The Sales Order created is not being shown in the ByDesign sales order OWL as this sales order is created from internet and the system is not scoped for automatic confirmation of sales order.
First of all you need to check the query response as per the example below, if the tag value have the value 1 which is not released, the sales order will not be displayed on the UI but the order is created and is present in the system.
<CustomerRequestReleaseStatusCode>1
</CustomerRequestReleaseStatusCode>
In order to fix the XML it is necessary to explicitly set the tag to true to release the sales order to UI by setting the value of tag given below as true in the create request or in the update request.
<ReleaseCustomerRequest>true</ReleaseCustomerRequest>.
We can change this behavior to happen automatically by changing the scoping for E-Commerce. To set or manage the sales order (created via web shop) release status you need to check the Business Configuration scoping questions and take appropriate actions:
- Go to the Business Configuration work center
- Go to the Implementation Projects view.
- Show All Projects and select the relevant one.
- Edit the Project Scope
- In Scoping, go to the section Questions -> Select Sales -> Selling Products and Services -> E-Selling -> Questions: Sales Order Release Procedures
- Would you like your customers to confirm sales orders that originate from an E-Shop with information calculated in the Business ByDesign system?
For the question 1, If you select Yes: This means that when a Sales Order is created the Request Release Status will be Not Released . This will change to Released when the operation SalesOrderActionIn -> ReleaseCustomerRequest is executed.
NOTE: The operation SalesOrderActionIn -> ReleaseCustomerRequest has to be executed from the Web Shop, this means customer has to release the customer request in the web shop itself. Unless this is executed the sales order will not appear on the user interface of Business ByDesign.
If you select No: Then you wouldn't not have to call the action SalesOrderActionIn -> ReleaseCustomerRequest (In web shop) to explicitly confirm the Order.
The order created by the webshop is confirmed and can be viewed by the ales representative. The sales order can be seen on the sales order interface.
Resolution
You can solve the issue by using one of the 3 options:
- Change your scoping options accordingly.
- Send a second call from the web shop with the element <ReleaseCustomerRequest>true</ReleaseCustomerRequest> to release the Sales Orders so they become visible in the UI.
- Set up an Internet Order Deletion Run to remove the Sales Orders for which no second call for releasing/explicitly confirming the Sales Order (ReleaseCustomerRequest) was sent.
You can set up an Internet Order Deletion Run as follows:
- Go to the E-Commerce work center.
- Select the Internet Order Deletion Runs view.
- Click on the New button.
- Maintain the respective data.
- Click on the Schedule button.
- Maintain the recurrence schedule in which the run should be executed.
- Click on the Set Activate button.
- Save the run.
Please note that you have to maintain both Sales Organization From/To and Distribution Channel From/To. In the Created Before field you can maintain the amount of e.g. days or hours, before the time of deletion. For example if the Sales Order was create yesterday and the Created Before is maintained as 1 Day(s), the run will remove the Sales Order.
See Also
1757249 - Sales Volume Report Show Incorrect Data
Keywords
ManageSalesOrderIn, Sales Order, cannot be found, OWL, Web Service, Sales Order missing , KBA , find , web service , owl , not available , cannot find , managesalesorderin , sales order volume , not visible , internet , AP-SLO , Sales Order Processing , SRD-CRM-ORD , Orders & Contracts , How To