Symptom
Service order remains in the Completed status even after the Cancelation of follow-up documents like service confirmation and customer invoice.
Reproducing the Issue
- Go to the Service Orders work center.
- Go to the Service Order Processing view.
- Show All Orders and Find XYZ (XYZ represents the ID of the service order).
- Edit the service order and choose View All button.
- Go to the Documents Flow tab, here you can see that the follow-up service confirmation and customer invoice are already canceled.
- Go to the General tab where the status of the service order is shown as Completed.
Cause
You have executed the service order with Complete Execution. Since the item is Completed it has changed to the status Completed.
If the confirmation is already done with Complete Execution, then the status of the service order will remain Completed even after cancelation of follow-up documents..
Resolution
This is the expected behavior of the SAP Business ByDesign.
Keywords
KBA , AP-SVO , Service Order Processing , How To
Product
SAP BUSINESS BYDESIGN 1705 ; SAP Business ByDesign 1602 ; SAP Business ByDesign 1605 ; SAP Business ByDesign 1608