Symptom
You have migrated the Customer Master Data using the Migration Tool. The migration is completed in the system without error, but you observed that the Account IDs are not same as per the migration template.
Reproducing the Issue
1. Go to Account Management work center.
2. Go to Accounts view.
3. Check the Accounts created using Migration tool.
Cause
During Data Migration, in step Convert Values, there is a task in the worklist Review Settings for Number Assignment for Customer IDs.
The choice is between
- Keep the old legacy numbers
- New numbers taken by migration Service
During processing of your first file, if you choose New numbers taken by migration Service then the new IDs for the Accounts have been taken according to the Number Range settings in Fine Tune, and a Value Conversion had been established.
or
During Data Migration, in step Convert Values, there is a task in the worklist Edit Value Conversion for Customer ID
The task is shown after first migration file. Here, you can choose the conversion for the Account ID, after that this conversion will taken for those Accounts.
Resolution
Based on above selection, the Account ID will be allocated to the Accounts.
This can also be verified using below steps,
- Open the Migration activity Migration of Customers.
- Select Migration of Customer using Migration Tool.
- Highlight the migration file and select Actions button and choose Download Value Conversion.
Here, you can find the conversion for the Account IDs.
Keywords
KBA , different account id after migration , AP-BP-BPT , Business Partner Template , How To