Symptom
You have set the Cancellation Reason in the contract item details, however the Cancellation Status is Cancellation Requested instead of Canceled.
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Contracts view.
- Open the respective contract and navigate to the Items tab.
- Select the respective line item.
- In the Cancellation part, you can see the Cancellation Reason has been selected. However, the cancellation status is Cancellation Requested.
You expect the cancellation status should be Canceled.
Cause
The item Contract Start/End range is not within the contract general range.
For example: On the header level (General tab), the Contract Start/End date is 31.03.2013-31.12.2999 , however on item level (Items tab) the line items Start/End date is 30.09.2009 - 31.12.2099.
Resolution
The items date range should always be within header date range. You have to change the Contract Start/End date in header in order to make sure that the item date range lie within header range.
See Also
1836112 - You are not Able to Cancel a Customer Contract
1753199 - You have select "Cancel Pending Invoice requests" for your Contract's Items But the Invoice Request are not Canceled
Keywords
KBA , AP-SLO , Sales Order Processing , How To