Symptom
You are not able to cancel a contract.
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Contracts view.
- Open certain contract and go to the Items sub tab.
- Select the row and you can see the Fulfillment is Not Started. But the Reason for Rejection field is grayed out.
You are not able to cancel this contract item.
Cause
There are many cases where users invoice a contract and then cancel it, due to this the Invoice Request goes into the status In Conflict. Considering this fact, we have changed the logic in such a manner that you will not be able to cancel a contract if it is invoiced.
Resolution
You have to first cancel the invoice and then the contract.
See Also
You can find the steps to cancel a customer contract in the case document: 1836112 - You are not Able to Cancel a Customer Contract
Since the Fulfillment Status of the Item is Finished for the reported contract, the Cancelation is not possible anymore.
Keywords
KBA , AP-SLO , Sales Order Processing , How To