Symptom
The system pops a window while accessing Adaptation Mode: PDI has Thrown an Exception, with message Logon User is not the Key User enabled for the solution (or) the message Enable the administration mode for the solution.
Reproducing the Issue
- Go to any workcenter/view.
- Select Adapt button and Enter Adaptation Mode from the drop-down.
- Select Edit This Screen, again from the same drop-down list.
Please note that the same message can also be encountered while the user tries to manipulate in the Form Template Maintenance view of the Application and User Management work center.
Cause
- Firstly, to be able to perform activities like editing screen in adaptation mode and form template maintenence, the logged-in user must be a key-user, meaning he/she must have the Application and User Management assigned.
-
If the logged-in user is a key-user, then this issue could occur when the business user logged-in is also used for PDI development in the OnDemand Studio. In such a case, the concerned user must be enabled with the Admin mode in the Studio.
Resolution
If case 1 is the cause, then try to perform the activity through a key-user.
If not, then it is caused because of the assignment of the Partner Development work center.
We strongly recommend to have separate users for PDI development and normal business user activities.
However, if you still want to use the same user in both scenarios, you can directly contact your implementation partners involved in development to enable Key-User mode for the concerned user in the OnDemand Studio.
To switch On/Off the Admin mode in the solution, the partner can use the Administration menu in the Studio.
Keywords
KBA , logon user , key user , pdi has thrown an exception , SRD-MD-PRD-PRD , Product , How To