Symptom
You try to upload an HTML file as a response template and the following error occurs: Solution configuration settings does not allow upload of HTML files.
Or: Only HTML files can be uploaded.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center.
- Open the Templates view.
- Add a new template.
- Select the channel type: email.
- Choose the document type base.
- Attach an HTML type file.
The error occurs.
Cause
By default, an html document upload is not supported by the system. You would need to allow it.
Resolution
- Go into Business Configuration work center.
- Select Implementation Projects view.
- Open the Activity List.
- Select the Fine-tune step.
- Choose to view All Activities.
- Find the Allowed Mime Types For Document Upload activity and open it.
- Set the mime type code 10082, Text/HTML document, as allowed.
- Save and Close.
Also please note: For each MIME type, you can maintain a default extension. The extension html should only be the default for 1 MIME type. Please ensure that no other MIME type has html as its default extension.
Keywords
service, template, mime type, extension, html, upload, replace, , KBA , LOD-CRM-SC-TMP , Template , How To