Symptom
- Parameter option, "Set To Null" is missing.
- For the same parameter, the checkbox is available in a different report.
- Set to Null checkbox is missing for some parameters in Crystal Reports.
Environment
- SAP Crystal Reports 2013
- SAP Crystal Reports 2016
- SAP Crystal Reports 2020
Reproducing the Issue
- Create a report using a Stored Procedure as a datasource in Crystal Reports.
- This Stored Procedure should have more than one parameter defined in it.
- Edit one of the parameter on report level and make it dynamic using the existing list of value(lov) from the Business View Manager.
- Now when one would refresh the report the checkbox goes missing.
- Now edit the parameter once again and select a different list of value.
- Refresh the report and the checkbox is available.
Cause
- The "Set to null" check box option appears only for parameters created in a Stored Procedure, or report based off an SAP BW BEx Query. ( It will not appear for report based off Tables, Views,... )
- Note that even if a parameter is created in a Stored Procedure, the option: "Set to null" will not appear when the Stored Procedure parameter is edited in Crystal Reports, and pointed to a List of Values (LOV), which is not based off a Stored Procedure.
Resolution
- In Crystal Reports, do not change the Stored Procedure parameter to point to a List of Values (LOV)
Keywords
prompt, lov, checkbox, set to null, database, bvm , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem
Product
SAP Crystal Reports 2013 ; SAP Crystal Reports 2016 ; SAP Crystal Reports 2020