SAP Knowledge Base Article - Public

1892892 - The Contact Name Does Not Appear in the Response Details of the Campaign

Symptom

The Contact Name does not appear in the Response Details of the Campaign.

Reproducing the Issue

  1. Go to the Marketing work center.
  2. Go to the Campaign view.
  3. Show Active Campaigns and Find campaign ID XYZ  (XYZ represents the ID of the campaign).
  4. Select the Campaign and choose Edit button.
  5. Select View All and navigate to Response Details tab.
  6. The Contact Name field do not display any data.

Cause

The contact is missing for response because the From party is maintained in the Response is Account instead of Contact. The system only shows the Contact Name in the Response Details of the campaign if the Form Party added in the campaign is a Contact.

You can check the Form Party in the response by following below steps:

  1. Go to the Marketing work center.
  2. Go to the Campaign view.
  3. Show Active Campaigns and Find Campaign ID XYZ  (XYZ represents the ID of the campaign).
  4. Select the campaign and choose Edit button.
  5. Select View All and navigate to Response Details tab.
  6. Select the Campaign ID to open it in a separate screen.
  7. You can find that the Form Party has Account ID.

Resolution

This is the expected behavior of SAP Business ByDesign.

Keywords

KBA , SRD-CRM-OPP , Opportunities , How To

Product

SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1711