Symptom
When creating a New Manual Invoice and selecting any account, the error message "Sales data or pricing terms not found for account" is displayed in the UI.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoice work center.
- Go to Common Tasks.
- Select New Manual Invoice.
- Click in the View all Button.
- Navigate to the Account and select any Account name.
An error message "Sales data or pricing terms not found for account" is triggered.
Cause
In order to allow the system to automatically find the maintained sales data for an account it is a prerequisite that the sales unit can also be determined automatically.
Resolution
- Go to the Organizational Management work center.
- Select the view Organizational Work Distribution.
- Navigate to the Business Area: Sales and Marketing.
- Maintain the rules: Sales Unit for Sales and Sales Unit for Manual Invoices.
The sales data will now be determined by the system and the error will not appear.
Alternatively it is also possible to manually enter the Sales Unit.
Please note: Even though the the Sales Unit is manually entered, that the error message will persist until the buffer is cleared e.g. by clicking button View All or adding a product.
See Also
Keywords
Manual Inovice; Sales data; Sales Unit; Pricing Terms; Account , KBA , AP-CI-CIR , Customer Invoice Request , How To