Symptom
When you migrate Customer, system throws below warning message,
No bank account maintained for the business partner
Reproducing the Issue
- Go to Business Configuration work center.
- Select Implementation Projects view.
- Select a project and select Open Activity List button.
- Go to Integrate and Extend phase.
- Open Migration of Customers and choose Migrate Customers using the Migration Tool.
- Execute Migration for the upload file.
The system triggered the warning messages Warning detected in source record with key value 'xxxxx' and Additional message generated; see help for more information. After clicking the Display Help link, the system triggers the message No bank account maintained for the business partner
Cause
If you maintain in sheet Payment Data, the Payment Method as Bank Transfer and if you did not maintain a corresponding bank for these customer, this warning appears. This behavior is also in the respective screen of Customer Master Data.
Resolution
For all customers in the file have this warning, maintain the respective information in the Bank Data sheet for the customers those who have payment method as Bank Transfer.
Keywords
KBA , AP-BP-BPT , Business Partner Template , How To