Symptom
The function assign reference for returns on item level does not work as expected.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Returns view.
- Show All Returns and Find XYZ (XYZ represents the ID of the return).
- Go to the Items tab and select the Assign Reference button.
- You assign reference Sales Order ABC(ABC is id of the sales order).
- You get an error message: Sales Order reference with ABC-XX not valid(ABC is the id of the sales order and XX is the line number of the product which you have as assigned reference).
Cause
This is the expected behavior, you can only assign a valid reference that is a sales order order with same product, otherwise the reference would not be valid.
Resolution
This is the expected behavior of SAP Business byDesign. If you want assign reference to any other sales order then you need the select the check box External Indicator in the Assign Reference tab of the Item for which you want to assign reference. After this you will be able to assign reference to any sales order in the system.
See Also
KBA 0003401203- In Customer Return Assign Reference at Item Level Does Not Work As Expected
Keywords
Customer Return; Assign Reference; Sales Order; Item; Error Message , KBA , AP-SVO , Service Order Processing , How To