Symptom
When using the search function in the Crystal Report viewer, it returns back the same result multiple times.
Environment
- CRSE 2011 SP6
- CRSE 2011 SP7
Reproducing the Issue
Option 1:
1. Retrieve the image ADAPT01706503_TE5000509947_i819003 - CRSE 2011 SP6 from Escalation Storage Catalog
2. Open a command window (cmd), go to c:\tomcat6 and run
bin\catalina run
3. After tomcat has started, start a browser and go to
http://localhost:8080/testRas2011/testLarge.jsp
4. Click on the search bar and search for 1,024
It will return an infinite number of results. The cause appears to be if the search term has a period or a comma in it.
Cause
This issue occurs if a comma or a period is used as part of the search term. It has been identified and logged under Problem Report ID ADAPT01706503
Resolution
There isn't currently any workaround for the issue except to remove and commas or periods from your search terms.
This issue has been resolved in SAP BusinessObjects Business Intelligence Platform 4.0 SP09 and SAP BusinessObjects Business Intelligence Platform 4.1 SP03
Keywords
Infinite, multiple, search, many, unlimited, repeated, RAS, OEM, 4.0, 4.1, SP03, SP09, Same result, search function, crystal report viewer, ADAPT01706503, ADAPT01706504, ADAPT01709151, ADAPT01710556 , KBA , adapt01706503 , BI-DEV-JAV , BI Software Development Kits (SDKs) - Java , Problem