Symptom
You are not able to modify the Customer Information field of a sales order item.
Reproducing the Issue
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Show All Orders and Find XYZ (XYZ represents the ID of the sales order).
- Edit the sales order and select the View All button.
- Go to the Items tab.
- Select the line item XXX (XXX represents the number of the line item).
- Select the Notes sub-tab.
- The Customer Information field is not editable for the line item XXX, however it is editable for the other line items.
Cause
The delivery status of the line item XXX of the sales order XYZ is already Finished, hence the Notes section is un-editable. However for other line items the delivery status is still In Process, hence the Notes section is editable for them.
This is a normal system behavior, sales order UI do not allow to edit any data of a line item which is already delivered (or for the line item whose delivery status is Finished).
You can check the delivery status of a line item by following below steps:
- Go to the Sales Orders work center.
- Go to the Sales Orders view.
- Show All Orders and Find XYZ (XYZ represents the ID of the sales order).
- Edit the sales order XYZ and select the View All button.
- Go to the Items tab.
- Select the line item XXX (XXX represents the number of the line item).
- Go to the Details sub-tab.
- You can find the delivery status of line item as Finished.
- However the delivery status for other line items is still In Process.
Resolution
This is the expected behavior of the SAP Business ByDesign system.
Keywords
KBA , AP-SLO , Sales Order Processing , How To