Symptom
When migrating Open Sales Order, system throws below error message:
Service call failed; report an case
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Configuration work center.
- Go to the Overview view.
- Find the Migration of Open Sales Orders activity.
- Select Migrate open sales orders using the migration tool.
- Execute Migration Step by Step.
Cause
The cause for the behavior might be:
- The Products assigned in the Sales Order is not activated for Sales.
- The Accounts assigned in the Sales Order doesn't exist in the system.
- The Accounts assigned in the Sales Order is in status Blocked.
- The Accounts assigned in the Sales Order is Active but there is no Address maintained in the Communication tab of the Account.
Resolution
Resolution for cause 1:
For any Sales Order if you are assigning an Account then the Account should be Active. So, in order to complete the migration of above Sales Orders (Status: Blocked), the status should be Active.
Resolution for cause 2:
For any Sales Order if you are assigning an Account then the Account should be Active and also the Account should have a valid Address. Maintain the address for the Account (tab Communication; sub tab Addresses)
Resolution for cause 3:
For any Sales Order if you are assigning a Product then the Product should have the Sales enabled.
Resolution for cause 4:
Maintain an Address in the Communication tab of the Account.
Keywords
Migration, Unable, Sales, ByD , KBA , service call failed , migrate open sales order , SRD-CC-MIG-CNT , Migration: Content , How To