Symptom
The error message Mandatory List Price missing for the price calculation is Triggered in a Customer Return.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Order work center.
- Go to the Returns view.
- Select and Edit Customer Return XYZ (XYZ represents the identification of the customer return).
The following error message is triggered: Mandatory List Price missing for the price calculation
Cause
- In case the Return was created with reference to an existing sales document:
Due to an inconsistency the price information was not passed successfully from the sales document and invoice to the customer return. - In case the Return was created with reference to an external sales document:
There is no valid Price in a Price List maintained for the respective product and therefore the List Price cannot be determined by the system.
Resolution
One of the workarounds below can be followed:
- Go to the Sales Order work center.
- Go to the Returns view.
- Select and Edit Customer Return XYZ.
- Go to View All and Select the Pricing tab.
- In the Total Pricing section, select the button Update Pricing and the option Completely or the option Keep Manual Change if there was a manual change in the return.
Or
- Go to the Sales Order work center.
- Go to the Returns view.
- Select and Edit Customer Return XYZ.
- In the Item Pricing section, expand the respective Item.
- Click the Add Row button.
- In the dropdown list for the Price Component select List Price
- In the Amount field, you can enter the respective Amount.
- Save.
See Also
3336850 - The Error Message "Price and Tax Calculation Not Possible" is Triggered in a Customer Return
Please check that the Price List to be applied on the Customer Return is valid for the Pricing Date displayed on the associated Sales Order.
Keywords
Price list, list price, item, customer return, price determination, error message, price calculation, valid, prix, détermination du prix, liste de prix, valide, retour client, message d'erreur, poste , KBA , AP-CRP-CR , Customer Return , How To