SAP Knowledge Base Article - Public

1938111 - Error Message "Instance with the same key already exists", While Creating a Product Category

Symptom

When you try to create a new Hierarchy in Product Category, system throws below error message:

Instance with the same key already exists

Reproducing the Issue

  1. Go to Product Data work center.
  2. Select Product Categories view.
  3. Select New Hierarchy button.

System throws above error message.

Cause

The issue might have occurred because of locking (ex: same screen open in another window or another user tried to create the hierarchy)

Resolution

Please check whether any other user is trying to create a New Hierarchy and try to create the Product category again.

Keywords

KBA , LOD-CRM , Cloud for Customer , How To

Product

SAP Business ByDesign all versions