SAP Knowledge Base Article - Public

1942224 - Error: "SF011:[Simba][Saleforce] (18) The table name does not exist. [Database Vendor Code: 18]" when refreshing a report in Crystal Reports

Symptom

  • Error: "Failed to retrieve data from the database. Details: SF011:[Simba][Saleforce](18) The table <Table Name> does not exist. [Database Vendor Code: 18]"
  • When attempting to create a new report off Salesforce.com using a command object, it displays the error.
  • When refreshing an existing report based off a Salesforce.com data source in Crystal Reports 2013, it displays the error.
  • When refreshing the same report in previous version of Crystal Reports, it refresh successfully.
        
           
  • Note: Images and data in this SAP Knowledge Base Article is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP Crystal Reports 2013
        
  • Salesforce.com

Reproducing the Issue

  1. In Crystal Reports 2011 or below, connect to a Salesforce.com data source.
  2. Write a SOQL query against the Salesforce.com data source like:
      
         select id, name from account
     
  3. The report refresh successfully.
  4. Save the report.
  5. Open the same report in Crystal Reports 2013, and refresh it.
    It will fail with an error like:

        "Failed to retrieve data from the database.
         Details: SF011:[Simba][Saleforce] (18) The table ‘account’ does not exist. [Database Vendor Code: 18]"
      

    KB02.png

Cause

  • This issue occurs because in Crystal Reports 2013, the SOQL query written is case sensitive, where it was not in previous versions.
  • The issue has been identified and logged under Problem Report ID ADAPT01712415

Resolution

  • The issue is resolved in the following product update:
            
    • Crystal Reports 2013:
      • Support Pack 03 and above
          
  • If you cannot apply the above product update for some time, then to resolve this issue, ensure the SOQL query use uppercases and lowercases where appropriate.
          
    • For example, if the SOQL query used is:

               select id, name from account

      It will fail. To resolve the issue, modify the SOQL query using uppercases where appropriate like:
         
               SELECT Id, Name FROM Account

Keywords

CR, Salesforce.com, Simba , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Bug Filed

Product

SAP Crystal Reports 2013