Symptom
You are trying to edit, change or upload a form template to the system, but error message "Enable the administration mode for the solution" is displayed.
Environment
- SAP Business ByDesign
- SAP Cloud for Customer
Reproducing the Issue
- Go to Form Template Maintenance work center view:
- In SAP Business ByDesign, within the Application and User Management work center.
- In SAP Cloud for Customer, within the Administrator work center.
- Find the relevant template.
- Click any button that would edit or change the form template.
- The error message is raised.
Cause
The user trying to edit the form template has the Development User role, which is granted when the user has has access to one of the views under the PDI_PARTNER_DEVELOPMENT - Partner Development work center.
Users cannot have the Key Business User (a.k.a. administrator) and Development User roles simultaneously to avoid inconsistencies. Hence, if a user with Development User role tries to edit the form template, the error message asks to enable Administration mode.
Resolution
Remove access to the PDI_PARTNER_DEVELOPMENT work center views from the user's access rights and this will revert the user to the Key Business User role.
If the user is required to work with PDI development, we suggest creating two separate business users: one with access to the PDI_PARTNER_DEVELOPMENT work center views—and thus the Development User role—and one without them, to do key user work that is not possible with a Development User role assigned (check the See Also section for more information).
See Also
Keywords
Enable the administration mode for the solution, form template, edit, change, upload, PDI Developer, development user, PDI_PARTNER_DEVELOPMENT , KBA , AP-RC-FF , Forms Flexibility , AP-RC-OUT , Output Management , How To