Symptom
How to cancel the Schedule Invoice Request for the Contract, when Contract Item's Fulfillment Status is Finished and the Invoice Status is Not Started.
Reproducing the Issue
- Go to the Sales Order work center.
- Go to the Contract view.
- In the Show field from drop-down select All Contracts and in the Find field enter PQR(where PQR is the contract id).
- Edit the Contract PQR and go to the Pricing and Invoicing tab and sub tab Invoice Schedule.
- Here the Contract->item is schedule for the date XX. YY. ZZZZ with the status as Open.
- Go to the Customer Invoicing work center.
- Go to the Invoice Request view .
- In the Show field from drop-down select All Invoice Request and in the Find field enter the Contract id PQR.
You will see the Schedule Invoice Request LMN(where LMN is schedule invoice request id) for the date XX. YY. ZZZZ reference to the Contract PQR is with status as To Be Invoice, which you want to cancel.
Cause
Since the scheduled Contract->Item in the Pricing and Invoicing tab and sub tab Invoice Schedule is with status as Open, the related Schedule Invoice Request LMN can be canceled.
Resolution
- Go to the Sales Order work center.
- Go to the Contract view.
- In the Show filed from drop-down select All Contract and in Find field enter PQR.
- Edit the Contract PQR and go to the Items tab.
- Select the Contract Item and click on the button Finish->Invoicing and Save the Contract.
This will change the status in the Contract->Item under the Invoice Schedule subtab from Open to Canceled and cancels the Schedule Invoice Request LMN.
Keywords
KBA , AP-SLO , Sales Order Processing , How To