SAP Knowledge Base Article - Public

1948400 - Fields in Completed Appointments are Editable

Symptom

After the status of an appointment is set to Completed some fields are still editable.

Reproducing the Issue

  1. Go to the Activites work center.
  2. Select the Appoinments view.
  3. From the selection drop-down, choose My Completed Appointments.
  4. Open the appointment XYZ (XYZ represents the name of the appointment).
  5. Some fields such as Account, Organizer, adding Follow-Up Items etc. are editable.

Cause

This is expected system behavior. Not all fields are blocked for edit on complete in order to assist the sales user and provide flexibility in related information. This is the behaviour currently in all activities, except visits since an actual time capture on visits is done. In all other activities, there is no time capture and hence, the additional step of moving the activity to In Process does not offer a significant benefit.

Resolution

Changing this behaviour has been considered for a future release.

Keywords

KBA , LOD-CRM-ACT , Activities , How To

Product

SAP Cloud for Customer core applications 1308 ; SAP Cloud for Customer core applications 1311 ; SAP Hybris Cloud for Customer add-ins 1708