Symptom
You have added a service item in a purchase order. The delivery date on the preview is incorrect.
Reproducing the Issue
1. Go to Purchase Requests and Orders work center.
2. Select Purchase Orders view.
3. Select Show All Purchase Orders and find 1021538.
4. Choose Go, select Edit and View All.
5. Choose Preview.
You see that delivery date shows as one day before than actual date.
Cause
This is standard system behavior. Service To date has been maintained as Date followed by 00:00Hrs, system considers it as 1 day before. This is the reason it shows service date/period as one day less than actual date. You need to enter either hrs or minutes in order to get the same date on output form.
Resolution
1. Go to Purchase Requests and Orders work center.
2. Select Purchase Orders view.
3. Select Show All Purchase Orders and find the relevant Purchase Order ID.
4. Choose Go, select Edit and View All.
5. Go to Items tab, under Basic Data sub tab.
6. Enter a value as hours and minutes under Service To field next to Date.
7. Press Enter and then Preview. Save the Changes.
You will see that Delivery Date/ Service Period shows correct date.
NOTE: This behavior is valid for all the time zones.
Keywords
KBA , SRD-CC , Cross Components , How To