SAP Knowledge Base Article - Public

1950186 - Purchase Order Delivery Date for Service Item Incorrect on Preview

Symptom

You have added a service item in a purchase order. The delivery date on the preview is incorrect.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Purchase Requests and Orders Work Center.
  2. Navigate to the Purchase Orders view.
  3. Select the Option All Purchase Orders.
  4. Query the record by the Purchase Order ID.
  5. Select Edit and View All.
  6. Choose Preview, you see that the delivery date shows as one day before than actual date.

Cause

Service To date has been maintained as Date followed by 00:00 hrs, system considers it as 1 day before. This is the reason it shows service date/period as one day less than actual date. This is standard system behavior.

Resolution

You need to enter either hrs or minutes in order to get the same date on output form.

  1. Go to the Purchase Requests and Orders Work Center.
  2. Navigate to the Purchase Orders view.
  3. Select the Option All Purchase Orders and find the relevant Purchase Order ID.
  4. Select Edit and View All.
  5. Navigate to the Items tab, under Basic Data sub-tab.
  6. Enter a value as hours and minutes under Service To field next to Date.
  7. Press Enter and then Preview. Save the Changes.

You will see that Delivery Date/ Service Period shows correct date.

NOTE: This behavior is valid for all the time zones.

Keywords

Purchase Order, Delivery Date, Service To, Preview, Incorrect, Wrong , KBA , purchase orders , delivery date , SRD-SRM-PRO , Purchase Requests and Orders , AP-POP-PO , Purchase Order , How To

Product

SAP Business ByDesign all versions