Symptom
The following error messages occur when trying to delete the standard value 0001 – Customer visit from the fine tuning activity Activities for the Appointment activity Type:
'Value 0001 in setting Visit Report Category must also be entered in setting Category Assignment';
'Unassigning category 0001 not possible; category in use';
'Save failed.'
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Business Configuration work center.
- Select the Implementation Projects view.
- Select the relevant Implementation project and click the Open Activity List button.
- Navigate to the Fine-Tune step and open Activities.
- Click the Assign Categories hyperlink
- Select 12 – Appointment as Activity Type and 0001 - Customer visit as Category for Appointment
- Click the Delete button.
- Click Save.
-
The following error messages occur:
'Value 0001 in setting Visit Report Category must also be entered in setting Category Assignment'.
'Unassigning category 0001 not possible; category in use'.
'Save failed'.
Cause
After your system goes live (Productive system), you will no longer be able to delete such an entry if it has been in use!
In the test system you need to first delete the Category in the Summaries fine tuning activity before you can delete it from the Appointment Category in the fine tuning activity.
Resolution
- Go to the Business Configuration work center.
- Select the Implementation Projects view.
- Select the First Implementation project and click the Open Activity List button.
- Navigate to the Fine-Tune step and open activity Summaries.
- Select Customer Visit and click the Delete button.
- Click the Save and Close button.
- Open the Activities activity in the Fine-Tune step.
- Click the Assign Categories hyperlink
- Select 12 – Appointment as Activity Type and 0001 - Customer visit as Category for Appointment
- Click the Delete button.
- Click Save and Close.
See Also
KBA 2661499 - Business Configuration: Delete Option Not Available
Keywords
Category, Appointment, Activities, 0001 - Customer visit, Fine Tuning, Delete , KBA , LOD-CRM-ACT , Activities , How To