Symptom
The approvals process for Supplier invoices is defined as:
Step1:
Work distribution: Supplier Invoice Approver
Conditions: Random Exception Check Percentage is Less than or equal to "100"
But, the Exception prone supplier invoice never undergoes for approval. Instead the approval tab of supplier invoice displays an error message:An approver could not be determined. Either approval is not relevant or the task is unassigned. Please contact your system administrator.
This is also applicable for the invoices without any exception, but with the message : "An approver could not be determined. Either approval is not relevant or the task is unassigned. Please contact your system administrator." in the Approval tab.
Reproducing the Issue
- Go to Supplier Invocing work center.
- Select the Invoices and Credit Memos view.
- Search for the respective Supplier Invoice ID and select Edit button.
- Navigate to the Approval tab.
- This message will be displayed : "An approver could not be determined. Either approval is not relevant or the task is unassigned. Please contact your system administrator."
Cause
The supplier invocie is not maintained with the invocing unit, so system failed to find the responsible approver.
Go to Application and User management work center -> Business task managemenet view -> search for the relevant Supplier invoice, no approval task will be available which indicated that the approval task itsel is not generated at all.
Resolution
To resolve the issue, maintain the invoicing unit in the supplier invoice.
Keywords
No approver determined, approval task not available , KBA , an approver could not be determined , AP-SIP , Supplier Invoice Processing , How To