Symptom
Employee replication in Cloud for Travel and Expense system fails with the error message Employee ABC(ID XXX) has more than one position assignment per time frame.
Reproducing the Issue
- Go to the Cockpit work center.
- Click on Failed/Not Started Employees link.
- Search for the employee ABC whose replication status is failed.
- Check the log under Log Items for Selected Employee for the error message.
Cause
Employee ABC has Personel Number XXX until DD.MM.YYYY.
You have attempted to add Personel Number YYY without limiting Personel Number XXX to an earlier date before Personel Number YYY begins.
This creates a time overlap and the system raises an error.
Resolution
Whenever you synchronise Personel Number YYY, you must synchronise Personel Number XXX too and make sure Personel Number XXX ends before Personel Number YYY begins.
If Personel Number XXX and Personel Number YYY do not overlap in your ERP system then you can proceed with the replication.
Else implement BADI OTM_EMPL_ORGANIZATION_FILTER so that it outputs non-overlapping periods for Personel Number XXX and Personel Number YYY.
This way ERP system supplies non-overlapping Personel Number's to Cloud for Travel and Expense system.
Keywords
KBA , LOD-TEM-IMD-EMP , Employee , How To