SAP Knowledge Base Article - Public

1966008 - Error Message "User Account Not in Validity Date" When Logging Into System

Symptom

When a user tries to log into their system with their user ID and password, system raises error message "User account not in validity date."

Environment

  • SAP Business ByDesign
  • SAP Cloud for Customer

Reproducing the Issue

  1. Access the tenant's URL in a web browser.
  2. In the logon screen, enter user ID and password.
  3. Click the Log On (SAP Business ByDesign) or Sign In (SAP Cloud for Customer) button.
  4. Error message is raised.

Cause

The business user's Valid To date was set to a date in the past, meaning that the user is not valid in the current date.

Resolution

To resolve this issue, a system administrator needs to extend the validity of the affected user so that the new validity includes the current.

To do that, please follow the below steps:

  1. Go to Business Users work center view.
    • In SAP Business ByDesign, within the Application and User Management work center
    • In SAP Cloud for Customer, within the Administrator work center.
  2. Change the selection to All Business Users.
  3. Using the search bar, locate the relevant business user.
  4. Click the Edit button, then select Attributes.
  5. In the Valid To field, set the date to a date in the future.
  6. Click the Save (or Save and Close) button.

Once the user's validity is extended, they will once again be able to log onto the system using their credentials.

Keywords

User Account Not in Validity Date, Logon, Business User, Credentials , KBA , logon , logon failed , login , SRD-CC-IAM , Identity & Access Management , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions