Symptom
The search query in the Supplier view does not work as expected while searching using Product Category ID and Engagement Status criteria.
Reproducing the Issue
To better understand the issue, consider the following example:
The below suppliers:
Supplier: A (S100000)
Supplier: B (S100001)
Supplier: C (S100002)
Are assigned the Product Category 100.
The initial Engagement Status for all three is set to 1 - In Pre-Evaluation.
The supplier query for Product Category 100 and Engagement Status: 1 - In Pre-Evaluation retrieves the expected results.
Now, change all the engagement statuses to 3 - Released For Purchasing, the query for the same will still work fine.
However, now the query for Product Category 100 and Engagement Status: 1 - In Pre-Evaluation still shows the same results as well.
Change the Engagement Status of the Product Category in Supplier: A (S100000) to 5 - Removed, the query Product Category 104 and Engagement Status: 5 - Removed gives only the supplier (S100000). However, all the previous queries still shows all three suppliers.
Cause
As per the current design of the system, the query pulls records which atleast once had obtained the Engagement Status equal to the parameter value.
Resolution
This is a known issue which will be fixed in a future release.
Keywords
KBA , supplier , engagement status , search , AP-BP-BPT , Business Partner Template , How To