Symptom
The Customer Information is not copied from the Contract to the Service Confirmation.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- From the Common Task, select the New Contract.
- In the New Contract screen within the General tab maintain all the mandatory information.
- Navigate to the Items tab.
- Click on the Add Row button.
- Add product LMN (where LMN is the item of type: Service - time and material).
- Scroll down to the Details section of product LMN.
- Navigate to the Notes subtab.
- Under the section Customer Information maintain the value.
- Save the Contract.
- The Contract ABC is created (where ABC is the Contract ID).
- Click the Submit button.
- Select the Release option to release the Contract.
- Click the Edit button for the Contract ABC.
- Click the Submit button and select Confirm Execution.
- In the New Service Confirmation screen click on the View All button and go to the Services and Spare Parts tab.
- Click on the Add Row button.
- Add the Reference Contract/Item.
- Navigate to the Notes subtab under Details.
You will see the Customer Information maintained in Contract ABC is missing in this reference Service Confirmation.
Cause
The Customer Information maintained in the Item of a Contract used to not be copied to the Service Confirmation up until the 2002 release of the system. From 2002 onwards, this was fixed.
Resolution
For Service Confirmations created before the 2002 release of the system, this is the expected behaviour. For Service Confirmations created after 2002, this is no longer the case and the Customer Information will be copied to the Service Confirmation.
Keywords
Contract, Service Confirmation, Customer Information , KBA , csg_q , AP-SLO , Sales Order Processing , How To