Symptom
When releasing and sending an invoice via e-mail the document will not be sent and the output history will be empty.
Environment
SAP Business Bydesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Go to the Invoicing view.
- Search for the invoice XYZ (XYZ represents the identification of your customer invoice)
- Click on Release button.
The e-mail is not generated and more over you do not see any documents in the tab output history.
Cause
There are no e-mail addresses maintained in the corporate account.
Resolution
Maintain an e-mail address in the corporate account under Communication Collaboration or under General tab, section Main communication, cancel the invoice and create a new one.
- Go to the Account Management work center.
- Go to the View Accounts.
- Select Account ABC, click Edit and General.
- Select the Communication tab and select Collaboration.
- Under Business Document Settings select Customer Invoice/Credit Memo,
- Activate the control and change the Output Channel To E-Mail.
- Maintain an e-mail address in the field E-Mail.
- Save and close.
Alternatively, maintain the e-mail address in the General section of the corporate account:
- Go to the Account Management work center.
- Go to the Account view.
- Select Account ABC, click Edit, General.
- Go to the section Main Communication.
- Enter an e-mail address in the field E-Mail.
Cancel the invoice:
- Go to the Customer Invoicing work center.
- Go to the Invoice Documents view.
- Select the invoice XYZ (XYZ represents the identification of your customer invoice);
- Click on Cancel to cancel the invoice.
Create a new invoice - you may create it as copy of the one which must be cancelled first, and cancel the former invoice.
- Go to the Customer Invoicing work center.
- Go to the Invoice Documents view.
- Select the invoice XYZ (XYZ represents the identification of your customer invoice);
- Click on Copy
- Generate the new invoice and release it;
- Cancel the old invoice.
Before releasing the the new invoice ensure that an email is now maintained in Edit Output Settings.
See Also
KBA 2097844 - No Output History Business Document but Preview is available
Keywords
Output History; No records found; Invoice document; Preview; Account Master data; Collobaration; E-mail , KBA , AP-CI , Customer Invoice Processing , How To