SAP Knowledge Base Article - Public

1981810 - Invoice Not Sent via E-Mail and No Output History Available

Symptom

When releasing and sending an invoice via e-mail the document will not be sent and the output history will be empty.

Environment

SAP Business Bydesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Go to the Invoicing view.
  3. Search for the invoice XYZ (XYZ represents the identification of your customer invoice)
  4. Click on Release button.

The e-mail is not generated and more over you do not see any documents in the tab output history.

Cause

There are no e-mail addresses maintained in the corporate account.

Resolution

Maintain an e-mail address in the corporate account under Communication Collaboration or under General tab, section Main communication, cancel the invoice and create a new one.

  1. Go to the Account Management work center.
  2. Go to the View Accounts.
  3. Select Account ABC, click Edit and General.
  4. Select the Communication tab and select Collaboration.
  5. Under Business Document Settings select Customer Invoice/Credit Memo,
  6. Activate the control and change the Output Channel To E-Mail.
  7. Maintain an e-mail address in the field E-Mail.
  8. Save and close.

Alternatively, maintain the e-mail address in the General section of the corporate account:

  1. Go to the Account Management work center.
  2. Go to the Account view.
  3. Select Account ABC, click Edit, General.
  4. Go to the section Main Communication.
  5. Enter an e-mail address in the field E-Mail.

Cancel the invoice:

  1. Go to the Customer Invoicing work center.
  2. Go to the Invoice Documents view.
  3. Select the invoice XYZ (XYZ represents the identification of your customer invoice);
  4. Click on Cancel to cancel the invoice.

 Create a new invoice - you may create it as copy of the one which must be cancelled first, and cancel the former invoice.

  1. Go to the Customer Invoicing work center.
  2. Go to the Invoice Documents view.
  3. Select the invoice XYZ (XYZ represents the identification of your customer invoice);
  4. Click on Copy
  5. Generate the new invoice and release it;
  6. Cancel the old invoice.

Before releasing the the new invoice ensure that an email is now maintained in Edit Output Settings.

See Also

KBA 2097844 - No Output History Business Document but Preview is available

Keywords

Output History; No records found; Invoice document; Preview; Account Master data; Collobaration; E-mail , KBA , AP-CI , Customer Invoice Processing , How To

Product

SAP Business ByDesign all versions