SAP Knowledge Base Article - Public

1982106 - Missing records in Crystal Reports connecting to TRAMS application (Interbase database)

Symptom

  • Subreports do not return data
  • Subreports are missing columns
  • The issue is  inconsistent, after restarting Crystal Reports Designer it could be another subreport missing records.

Environment

  • Crystal Reports 2008
  • SAP Crystal Reports 2011
  • SAP Crystal Reports 2013
  • TRAMS application
  • Interbase XE database
  • DataDirect ODBC driver for Interbase 

Reproducing the Issue

  1. Refresh Crystal report with multiple subreports connected to Interbase database in Crystal Reports Designer 2011
  2. Notice some of the subreports are empty or missing records or columns.

Cause

The problem caused by the DataDirect ODBC driver

Resolution

Replace the driver with EasySoft ODBC driver for Interbase: http://www.easysoft.com/products/data_access/odbc_interbase_driver/index.html

or

contact the TRAMS application vendor to fix or replace the driver. The vendor has some versions of the Interbase shipped with EasySoft driver (see: http://static.trams.com/tramslibrary/reports/TCR10.pdf)

Keywords

empty, zeroes, incorrect results  , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

Crystal Reports 2008 V1 ; SAP Crystal Reports 2011 ; SAP Crystal Reports 2011, feature pack 03 ; SAP Crystal Reports 2013