SAP Knowledge Base Article - Public

1992148 - Error Message: Employee ID missing

Symptom

When assigning credit card or mobile expenses to an Expense Report, you receive an error message stating Employee ID missing and you are not able to save the Expense Report.

Reproducing the Issue

  1. Login as a Traveler.
  2. Go to the Travel & Expenses work center.
  3. Go to the Travel & Expenses View.
  4. Open the Expense Report.
  5. Assign credit card or mobile expenses from the UI buffer link, You have XX expense(s) to assign to an expense report.

Cause

 The error message Employee ID missing appears when you open some of the old expense reports. These expense reports are consistent and need not be changed.

Resolution

The upcoming error message Employee ID missing can be ignored and for all new expense reports this error message will not appear.

If you have to change one of these old expense reports from business point of view, you can delete and re-enter the cost assignment at expense level in order to get rid of this error message:

  1. Go to the Travel & Expenses work center.
  2. Go to the Travel & Expenses View.
  3. Open the Expense Report.
  4. Delete and re-enter the Cost Assignment field value.

Keywords

KBA , LOD-TEM-ADM , Travel Administration , How To

Product

SAP Cloud for Travel and Expense 1402 ; SAP Cloud for Travel and Expense 1405