SAP Knowledge Base Article - Public

1998519 - Supplier Invoice with Accepted Exception Not Sent to Approval

Symptom

You have set in your system that all supplier invoices that have an accepted exception should be sent to approval, however for a specific invoice, the approval process was not triggered.

Reproducing the Issue

  1. Go to the work center Supplier Invoicing
  2. Go to the view Invoices and Credit Memos
  3. Select a Supplier Invoice that once had the status Exception
  4. Click on Post
  5. The invoice is posted without approval

However, in supplier invoice approval process, you have set condition Random Exception Check Percentage equal to 100. You expect all supplier invoices that have an accepted exception should be sent to approval.

Cause

The exceptions were created and accepted by different users.

If the user that accepted the exception is not the same one that have created it, the approval process will not be triggered, since there are two users involved.

This can be confirmed by accessing the Exceptions tab of the supplier invoice, selecting the accepted exception and clicking on Action Log. You will see that the user that created the exception is not the one who accepted it.

Please note,

  • Stochastic exception approval is applicable only for manually created supplier invoice.
  • Missing Purchase Order reference exception is not applicable during stochastic exception approval determination.
  • If the exception has been accepted more than once, then only the last acceptor party is considered.

Resolution

This is a standard behavior. The approval process will only be triggered if the same user creates and accepts the exception. Then, the approval of a second user will be necessary

See Also

KBA :Approvals is skipped in supplier invoice

https://itsm.services.sap/kb_view.do?sysparm_article=KB0766580

Keywords

Supplier Invoice Approval,  Random Exception Check, Approval Not Triggered , KBA , AP-SIP-SIV , Supplier Invoice , How To

Product

SAP Business ByDesign all versions