Symptom
You have added extension to a particular screen/object in the User Interface through Partner Developed Extensions, but the same fields are missing in the Migration Template for the respective objects.
Reproducing the Issue
- Go to Business Configuration work center.
- Find and open the Migration activity for the concerned object.
- Through the migration tool, download the migration template.
The extension fields are missing.
Cause
When it comes to migration templates customer extension fields[created through Adaptation mode] work differently from partner extension fields.
In the partner case one has to propagate the partner extension fields into the respective migration service by using a Process Extension Scenario which includes the respective migration service. So the partner has to create at first a process extension scenario that includes this migration service and then has to apply this process extension scenario to the partner extension fields via the Scenario annotation. As soon as this is done the partner extension field can be used in migration templates.
Resolution
Please inform the partner responsible for the extended objects to act as advised above.
Keywords
KBA , migration , adaptation , extension field , SRD-CC-MIG-CNT , Migration: Content , How To