SAP Knowledge Base Article - Public

2008597 - Extension Fields not Available in the Respective Migration Templates

Symptom

An extension field has been added to a specific screen/object in the User Interface through Partner Developed Extensions, however, the corresponding fields are not present in the migration template for the respective object.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Business Configuration work center.Select the Overview view.
  2. Locate and open the Migration activity related to the relevant object.
  3. Use the migration tool to download the migration template.
  4. Note that the extension fields are not included in the downloaded template.

Cause

When working with migration templates, customer extension fields (created via Adaptation Mode) behave differently from partner extension fields.

For partner-developed extensions, the custom fields must be explicitly propagated to the relevant migration service. This is done by creating a Process Extension Scenario that includes the appropriate migration service. Once the scenario is created, it must be linked to the partner extension fields using the Scenario annotation.

Only after this configuration is complete will the partner extension fields become available in the migration templates.

Resolution

The responsible partner should be informed to perform the necessary steps as described above.

Keywords

Migration Template, Missing, Custom fields, Extension fields , KBA , migration , adaptation , extension field , SRD-CC-MIG-DMC , Migration: Tool , How To

Product

SAP Business ByDesign all versions